Нет звука и eth0

Автор: Fildy Дата: 03.11.2007 13:10 в линуксе нуб, так особо не не ругайте. седня поставил асп 11.2. звука нет. попытался сделать поиск звуковых плат, говорит,что таких нету. ладно,думаю пока впн поднять попробую. пишу ifconfig eth0. пишет,что сей девай не найден...мать asus m2n-x...как я понимаю дров на диске нет. где можно их скачать?
Re: нет звука и eth0 03.11.2007 17:27wildsin я устал повторять... учитесь ПРАВИЛЬНО задавать вопросы...

[ln.com.ua]
Re: нет звука и eth0 03.11.2007 18:21Fildy что не правильно? вопрос где можно найти драйвера материники asus m2n-x под асп 11.2? смотрел на асус ру. там нет.
Re: нет звука и eth0 03.11.2007 18:28Fildy звуковуха realtek High Definition Audio. сетевуха - nvidia nforce networking controller. все встроенное в мать. обе не видит. вот и вся проблема.
Re: нет звука и eth0 03.11.2007 21:08BigAndy >часть машин бездисковый цеплются к X-серверу при помощи LTSP
А это как вы определили, что не видет?
Приведите диагностику.
Re: нет звука и eth0 03.11.2007 21:43Fildy при установке список сетевых адаптеров был пуст. там бы список предлагаемых драйверов как я понял. пробовал добавить. добавились несколько, но при попытке отстроить сеть при установке выдавалось сообщения,что они не подходят. теперь насчет звука. пробовал делать "найти звуковую плату", писал,что не найдено. когда пытаюсь в громкость зайти,то выдает сообщение что якобы gstreamer не правильно установлен, либо устройство не распознано.
Re: нет звука и eth0 03.11.2007 22:16bat BigAndy писал(а):

> А это как вы определили, что не видет?
> Приведите диагностику.
BigAndy имел ввиду, минимум, что надо сделать, это в консоли ввести команду
---
lspci
---
Скопировать вывод команды и показать здесь. Воспользоваться поиском.
Прошу прощения, если не верно расшифровал.
Re: нет звука и eth0 04.11.2007 15:44Fildy 00:00.0 RAM memory: nVidia Corporation MCP65 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP65 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP65 SMBus (rev a1)
00:01.2 RAM memory: nVidia Corporation MCP65 Memory Controller (rev a1)
00:02.0 USB Controller: nVidia Corporation MCP65 USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP65 USB Controller (rev a1)
00:06.0 Ethernet controller: nVidia Corporation MCP65 Ethernet (rev a1)
00:07.0 Audio device: nVidia Corporation MCP65 High Definition Audio (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP65 PCI bridge (rev a1)
00:09.0 IDE interface: nVidia Corporation MCP65 IDE (rev a1)
00:0a.0 IDE interface: nVidia Corporation MCP65 SATA Controller (rev a1)
00:0b.0 PCI bridge: nVidia Corporation Unknown device 045b (rev a1)
00:0c.0 PCI bridge: nVidia Corporation MCP65 PCI Express bridge (rev a1)
00:0d.0 PCI bridge: nVidia Corporation MCP65 PCI Express bridge (rev a1)
00:0e.0 PCI bridge: nVidia Corporation MCP65 PCI Express bridge (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
04:00.0 VGA compatible controller: nVidia Corporation GeForce 7300 LE (rev a1)
вот, что выдала lspci. тут звуковуха и сетевушка видны. тогда логичный вопрос, почему звука нет? и какой устройство использовать вместо eth0. залез в /dev там есть nvidia0, nvidia1, nvidia2. может что то из этого? вообщем жду совета:-)
Re: нет звука и eth0 04.11.2007 16:34bat Давайте посмотрим как у вас сконфигурировано устройство eth0:
---
# cat /etc/sysconfig/network-scripts/ifcfg-eth0
---
Re: нет звука и eth0 04.11.2007 16:36BigAndy ЗВук пробуйте прикрутить в ALSA, а не к Gstreamer, как по умолчанию. Его вообще надо прибить. А ALSa обновить
Re: нет звука и eth0 04.11.2007 17:05Fildy >Давайте посмотрим как у вас сконфигурировано устройство eth0:
данного файла нет...
Re: нет звука и eth0 04.11.2007 17:08Fildy >ЗВук пробуйте прикрутить в ALSA, а не к Gstreamer, как по умолчанию. Его вообще надо прибить. А ALSa обновить
можно подробнее? мои познания в этой ОС не такие хорошие. что такое alsa, и как ее обновить?
Re: нет звука и eth0 04.11.2007 17:48bat Fildy писал(а):

> >Давайте посмотрим как у вас сконфигурировано устройство eth0:
> данного файла нет...
Создаем, примерно так:
[forum.asplinux.ru]
[forum.asplinux.ru]
Re: нет звука и eth0 04.11.2007 18:51Fildy >Создаем, примерно так:
такой вопрос. в /etc/modules.conf прописывается alias eth0 tg3. tg3 как я понимаю драйвер. как мне узнать какой мой? в каталоге этих драйверов много. а tg3 как я понял именно для broadcom.
Re: нет звука и eth0 04.11.2007 18:54bat Fildy писал(а):

> >ЗВук пробуйте прикрутить в ALSA, а не к Gstreamer, как по
> >умолчанию. Его вообще надо прибить. А ALSa обновить
> можно подробнее? мои познания в этой ОС не такие хорошие. что такое alsa,
[ru.wikipedia.org]
---
Материал из Википедии — свободной энциклопедии

Продвинутая Звуковая Архитектура Linux (англ. Advanced Linux Sound Architecture, ALSA)
Архитектура звуковых драйверов, а также широкий их набор для Linux, призванный сменить Open Sound System (OSS).

Особенности

* Эффективная поддержка всех типов звуковых интерфейсов, от любительских до профессиональных многоканальных
интерфейсов.
* Поддержка более старого OSS API, обеспечение бинарной совместимости для большинства OSS программ.
---
> и как ее обновить?
в консоли:
---
yum update alsa*
---
Re: нет звука и eth0 04.11.2007 18:57BigAndy Для начала смотрите lsmod, подключен ли модуль для вашей сетевой карты, если не подключет, подлючаете командой modprobe. Потом уже создаем интерфейс в modules.conf.
Можно еще вызвать system-config-network и настроить сеть через него.

>мои познания в этой ОС не такие хорошие. что такое alsa, и как ее обновить?

ОБновления/долбавления/деинсталяция производятся через утилиты rpm и yum. Последний предпочтительнее, поскольку сам разрешает зависимости.
SIG Не забудте настроить репозитарии /etc/yum.repos.d

Документация по теме:
man yum
man rpm
man modprobe
man lsmod
man modules.conf
Re: нет звука и eth0 04.11.2007 19:31Fildy пробовал с помощью system-config-network. там есть выбор сетевых карт. у меня если верить диспетчеру устройств windows nVidia nForce Networking Controller. такого там близко нет. пробовал ставить риалтек и еще несколько,но при активации выдавалось сообщение,что устройства нет.
Re: нет звука и eth0 05.11.2007 21:34Fildy ну что? у кого-нить будут какие-нить идеи,кроме пересобирания ядра? мож сетевушку обычную взять? но вот звук...если потом alsa обновлю он вообще будет?..
Re: нет звука и eth0 06.11.2007 08:05Bircoph lsmod вы так и не показали, модули подгружить даже не
пытались, а телепатов тут нет...
Re: нет звука и eth0 08.11.2007 15:10Eraserus Народ, ну осильте кто нибудь напишите кто нидь по пунктам человеку что надо сделать, он же сам сказал НУБ... Новичок т.е.
Улыбка
RSS-материал