ASPLoader

Автор: Bircoph Дата: 09.02.2004 09:34 Уважаемые разработчики ASPLinux, к вам есть немколько предложений и пожеланий:

1) Ну почему ASPLoader такой назойливый? Сделали свой загрузчик - хорошо, но зачем его пихать, когда не просят. Проблема вот в чем: после обновления ядра (патч из раздела обновлений для ASP 9), а так же после обновления ряда пакетов (точно сказать каких не могу: я их устанавливал много до перезагрузки :Улыбка, но такое подозрение, что это dev-xxx-i386.rpm) вместо любимого grub появляется alpldr. Мне просто надоело восстанавливать всё время grub. Ну зачем так делать? Ладно, я понимаю, что после замены ядра может возникнуть необходимость смены параметров загрузки, ну так сделайте поддержку не только для aspldr, но и для lilo и grub - это ведь тоже широко распотраненные загрузчики. Пусть при возникновении необходимости изменить параметры загрузки, загрузчик определяется автоматически (или дается запрос пользоователю) и меняются параметры конкретного загрузчика, вместо затирания онгого aspldr. Не думаю, что это так сложно.

2) Установщик ASPLinux 9 при возникновении ошибки чтения с устройства (в моем случае это CD) прерывает установку с ошибкой i/o error (или что-то вроде того). Это не есть гуд, т.к. у меня комп отнюдь не новый и сидюк плохо, но работает. Особенно обидно, когда до конца установки оставались считанные проценты, а ведь на выбор пакетов может и час уйти. По-моему, лучше чтоб программа установки сообщила пользователю, дескать так и так, не могу прочитать такой-то файл, и предложила на выбор: повторить попытку, игнорировать (т.е. продолжить), прервать установку. Я, например, могу заставить CD-ROM прочитать файл, несколько раз перемонтировав устройство (высунув/вставив диск). Ну и не у меня одного такая проблема: при установке по сети может, например, прерваться связь. Не нужно тупо убивать установку из-за ошибки чтения. Учтите, пожалуйста, в следующих дистрибутивах.

3) Если начать установку ASPLinux 9 из под винды (с помощью Espresso download), но затем (после перезагрузки) использовать CD, сделанные со скачанных с вышего сайта образов, (это необходимо, когда нет FAT разделов, а есть только NTFS и место под Линукс) то первый и второй диски при установке распознаются нормально, а вот третий - никак, хотя он читается (проверил, примонтировав его из консоли, доступной в процессе установки) и записан точно так же, как и остальные. Это можно исправить, используя 1-й диск как загрузочный, но всё равно, ошибка не приятна, надо бы исправить.

А так выражаю разработчикам огромную благодарность за лучший, на мой взгляд, дистрибутив Линукса. Alt, Mandrake и т.п. мне не понравились (это мое субъективное мнение, так что без обид). Ждем-с новой версии ASP на ядре 2.6, неплохо бы включить в поставку supermount. Творческих узбеков!
Re: ASPLoader 15.02.2004 16:51dj_maxx Bircoph писал(а):

> Уважаемые разработчики ASPLinux, к вам есть немколько
> предложений и пожеланий:
>
> 1) Ну почему ASPLoader такой назойливый? Сделали свой
> загрузчик - хорошо, но зачем его пихать, когда не просят.
> Проблема вот в чем: после обновления ядра (патч из раздела
> обновлений для ASP 9), а так же после обновления ряда пакетов
> (точно сказать каких не могу: я их устанавливал много до
> перезагрузки :Улыбка, но такое подозрение, что это
> dev-xxx-i386.rpm) вместо любимого grub появляется alpldr. Мне
> просто надоело восстанавливать всё время grub. Ну зачем так
> делать? Ладно, я понимаю, что после замены ядра может
> возникнуть необходимость смены параметров загрузки, ну так
> сделайте поддержку не только для aspldr, но и для lilo и grub -
> это ведь тоже широко распотраненные загрузчики. Пусть при
> возникновении необходимости изменить параметры загрузки,
> загрузчик определяется автоматически (или дается запрос
> пользоователю) и меняются параметры конкретного загрузчика,
> вместо затирания онгого aspldr. Не думаю, что это так сложно.
>
ну вообще-то при установке ядра make install делать менее чем желательно Улыбка
make modules_install
а ядро скопировать в /boot ручками из arch/i386/boot/bzImage
Re: ASPLoader 15.02.2004 20:06Tigro 1-й пункт фиксился и даже когда-то работал нормально, сейчас правдо не работает:-) как надо, но и asploader не прописывает.
Это проблема в mkinitrd кажется.
RSS-материал