Установка ASPLinux 14 на разделы от 12

Автор: judge_aleks Дата: 19.01.2009 19:56
Решил поставить 14 версию запустил установку дошло дело до разделов и точек монтирования. У меня на компе два физических диска hda1 и hdb1 вся система устанавливается на hda1 а вот раздел /home я полностью поставил на hdb1 при указани разделов я его не трогал следовательно он в системе не появился! Операционка загрузилась спросила как будет называтся учётка я написал как было до этого, но она не поднялась комп после перезагрузке просто выдал приглашение и всё. Зашёл под root посмотрел в файловой системе есть каталог /home но вот он какой то не правильный. и моих файлов не видно которые были до этого. Вопрос как подмонтировать хард hdb1 с разделом /home? чтобы он грузился вместе с системой.

Заранее спасибо Улыбка

Re: Установка ASPLinux 14 на разделы от 12 19.01.2009 20:13blH,
Зайти под рутом. Cнести всё содержимое каталога /home и затем отредактировать файл /etc/fstab, добавив в нем запись

/home /dev/hdb1 ext3 defaults 1 2

Потом перезагрузиться...

а вообще, любопытно взглянуть сперва, что у вас в нем сейчас написано...

Re: Установка ASPLinux 14 на разделы от 12 21.01.2009 05:53judge_aleks
> а вообще, любопытно взглянуть сперва, что у вас в
> нем сейчас написано...

сейчас выложить не могу так как пишу с работы. Самое интересное то что я немного разобрался и выяснил что в fstab прописывается не просто /dev/hdb1 /home ext3 defaults 1 2, харды индентифицируются по UUID и прописываются так же! В /dev/disk/....(чего то там не помню) лежит файлики с таким названием я вычислил который из них мой бывший раздел /home добавил строчку в fstab. Оказывается система по разному определяет харды на этапе установки и работы. При установке он у меня его определил как hdb1 а уже в рабочей системе он sdb1 воо как! Ну да ладно с этим разобрался.Система грузится хард монтируется только вот X Server упал загружается только консоль. Наверное из за того что /home раздела небыло.Командую startx нифига не хочет вылетает с ошибкой. Вопрос что можно сделать? как переустановить X Server с установочного диска?

Re: Установка ASPLinux 14 на разделы от 12 21.01.2009 06:10judge_aleks
кстати после редакции fstab, initrd надо пересоздовать? Если надо то как?

Улыбка

Re: Установка ASPLinux 14 на разделы от 12 21.01.2009 07:16blH,
judge_aleks Пишет:
-------------------------------------------------------
> сейчас выложить не могу так как пишу с работы.

Ждём-с...

> Самое интересное то что я немного разобрался и
> выяснил что в fstab прописывается не просто
> /dev/hdb1 /home ext3 defaults 1 2, харды
> индентифицируются по UUID и прописываются так же!

Поэтому я и попросил выложить fstab.

> только вот X Server упал загружается только
> консоль. Наверное из за того что /home раздела
> небыло.Командую startx нифига не хочет вылетает с
> ошибкой. Вопрос что можно сделать? как
> переустановить X Server с установочного диска?

Дык заведите раздел /home и делов-то. Или переустановите систему целиком (только пропишите сразу при переустановке /dev/sdb1 как home -- но проще всё же поиграть с /etc/fstab)

Re: Установка ASPLinux 14 на разделы от 12 21.01.2009 08:00judge_aleks
blH, Пишет:

> Дык заведите раздел /home и делов-то.
завел, он теперь активный я же поправил fstab. Но иксы так и не грузятся Грустный

> переустановите систему целиком (только пропишите
> сразу при переустановке /dev/sdb1 как home

Как при переустановке сказать чтобы он сразу взял правильный раздел?

Re: Установка ASPLinux 14 на разделы от 12 21.01.2009 10:07Napilnik
ФОРМАТИРОВАТЬ раздел и указать точку монтирования /home/username Если данные на разделе удалять не хочется, можно попробовать обмануть систему. Подключить другой однотипный винт, отфарматировать при установке, а после поставить вместо него другой, с данными. В винде подобные трюки при переносе оси на другой винт прокатывают, как отреагирует на это линукс, не проверял. Во всяком случае, на отформатированном винте запишутся файлы которые можно перенести на другой девайс.
Re: Установка ASPLinux 14 на разделы от 12 21.01.2009 10:45judge_aleks
Napilnik Пишет:
-------------------------------------------------------
> ФОРМАТИРОВАТЬ раздел и указать точку монтирования

форматировать нельзя!!! инфо важное, другого винта нету. Буду колдовать с fstab

Re: Установка ASPLinux 14 на разделы от 12 21.01.2009 13:39blH,
judge_aleks Пишет:
-------------------------------------------------------
> > Дык заведите раздел /home и делов-то.
> завел, он теперь активный я же поправил fstab. Но
> иксы так и не грузятся Грустный
>
Ну показали бы, как поправили... кстати, а после поправки из "старого" /home в новый всё скопировали? И делали всё это под рутом?

> Как при переустановке сказать чтобы он сразу взял
> правильный раздел?
Щас буду вспоминать, как там всё было...

Значит, в том месте где установщик Вам предлагает свою конфигурацию дисков, Вы вместо того, чтобы согласиться с его разбиением, делаете своё. Мышкуете на нужный раздел диска и вместо "создать" говорите "изменить". После чего в опциях говорите, что форматировать /dev/sdb1 не надо -- зато надо присвоить ему точку монтирования /home.

Re: Установка ASPLinux 14 на разделы от 12 21.01.2009 17:31judge_aleks
blH, Пишет:
-------------------------------------------------------

> что форматировать /dev/sdb1 не надо -- зато надо
> присвоить ему точку монтирования /home.

Так не получается я сегодня попробывал! Короче переустановил я систему, тока хитро!!! начал установку как обычно разбил разделы ну и т д раздел /home не трогал оставил как есть потом дождался пока всё установится и когда он потребовал перегрузится я вставил LiveCD и поправил fstab вот он кстати: как обещал,

UUID=85abbcef-250c-4136-86e7-8c428caab174 / ext3 defaults 1 1
UUID=5d94b395-0f8c-4484-841f-416cf9e51c54 /home ext3 defaults 1 2 # это я вписал!!!
UUID=1932030d-16c2-4ffb-8737-e45395ad3f25 /var ext3 defaults 1 2
UUID=6fd64df9-e6cc-4b43-9556-859e5781d604 /tmp ext3 defaults 1 2
UUID=3d9835d9-06f3-41d6-ac76-5dea6a716f7e /usr ext3 defaults 1 2
UUID=1f13c716-334a-4856-926d-cd588e96f69f /usr/local ext3 defaults 1 2
UUID=2e32eac3-eca1-42d8-8fdf-b3726b71d58e /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
UUID=aa61b26b-49e5-409a-b61e-f8d19c1d2d2f swap swap defaults 0 0

каталог /home уже существовал но был пустой! Дальше перезагрузка начальная настройка и о чудо всё сраслось!
UUID я взял из каталога /dev/disk/by-uuid. Вот и всё!

blH спасибо за участие

Re: Установка ASPLinux 14 на разделы от 12 21.01.2009 19:10blH,
Кушайте на здоровье... Улыбка

Хотя мне и непонятно, что там могло "не получиться" при установке с готовыми разделами (в т ч /home) -- сам я только так и устанавливаю...

Re: Установка ASPLinux 14 на разделы от 12 25.01.2009 11:27val-888
Здравствуйте.
Если не сложно подскажите пожалуйста .
После установки ASPLinux 14 на один HDD с Windows XP MCE запускается в командной строке.
Объясняю: HDD 250G размечен на 3 прим раздела.
На первом стоит XP MCE, второй разбит на три логических диск и третий выделен под linux.
Установка прошла на ура ну то есть без замечаний. Ввел логин и пароль пользователя и все (ну то есть командная строка).
Перезагрузка толку не дает.
Помогите пожалуйста.
Re: Установка ASPLinux 14 на разделы от 12 25.01.2009 12:37msv2
1. Что написано на экране в точности?
2. Может быть следовало раздел /boot расположить в пределах 8 гб от начала диска(физического диска)?
Re: Установка ASPLinux 14 на разделы от 12 25.01.2009 12:43lkanter
Сообщения об ошибке должны быть в /var/log/Xorg.0.log

Зафиксированы случаи, когда на машины с встроенной графикой Intel устанавливается драйвер из-за ошибки при сборке пакета fglrx. Возможно, это именно такой случай. Если у вас графика Intel а в /etc/X11/xorg.conf прописан драйвер fglrx - выполните команду:

# rpm -e `rpm -qa | grep fglrx`

Кавычки нужно использовать те, которые на кнопке ~/Ё

Re: Установка ASPLinux 14 на разделы от 12 27.01.2009 02:16val-888
Я извиняюсь ,с трудом подключил linux раздел к винде .
Вот текст файла Xorg.0.log :

X.Org X Server 1.5.0
Release Date:
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-53.1.21.el5.asp121 i686
Current Operating System: Linux WAR 2.6.26.3-29.0.140asp.i686 #1 SMP Mon Sep 15 07:08:05 EDT 2008 i686
Build Date: 23 September 2008 10:39:49AM
Build ID: xorg-x11-server 1.5.0-2.0.140asp
Before reporting problems, check [wiki.x.org]
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jan 28 02:46:04 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "<default monitor>"
(**) | |-->Device "Videocard0"
(==) No monitor specified for screen "Screen0".
Using a default monitor configuration.
(**) |-->Input Device "Keyboard0"
(**) Option "AIGLX" "on"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
catalogue:/etc/X11/fontpath.d,
built-ins
(**) ModulePath set to "/usr/lib/xorg/modules/extensions/fglrx,/usr/lib/xorg/modules"
(**) Extension "Composite" is enabled
(==) |-->Input Device "<default pointer>"
(==) The core pointer device wasn't specified explicitly in the layout.
Using the default mouse configuration.
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81ee400
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 4.1
X.Org XInput driver : 2.1
X.Org Server Extension : 1.1
X.Org Font Renderer : 0.6
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0@0:2:0) Intel Corporation 82915G/GV/910GL Integrated Graphics Controller rev 14, Mem @ 0xfea80000/0, 0xd0000000/0, 0xfea40000/0, I/O @ 0x0000dc00/0
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX
(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.5.0, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SELinux
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"

(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.5.0, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 7.4.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 1.1
(**) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "freetype"

(II) Loading /usr/lib/xorg/modules/fonts//libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 1.5.0, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "dri"

(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 7.4.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "fglrx"

(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
compiled for 1.4.99.906, module version = 8.54.3
Module class: X.Org Video Driver
(II) LoadModule: "kbd"

(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 1.4.99.901, module version = 1.3.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) LoadModule: "mouse"

(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 1.4.99.901, module version = 1.3.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) Primary Device is: PCI 00@00:02:0
(WW) Falling back to old probe method for fglrx
(II) ATI Proprietary Linux Driver Version Identifier:8.54.3
(II) ATI Proprietary Linux Driver Release Identifier: UNSUPPORTED-8.543.2
(II) ATI Proprietary Linux Driver Build Date: Oct 10 2008 21:37:39
(WW) This ATI Proprietary Linux Driver does not guarantee support of video driver ABI higher than 2.0
(WW) Video driver ABI version of the X server is 4.1
(EE) No devices detected.

Fatal server error:
no screens found

Re: Установка ASPLinux 14 на разделы от 12 27.01.2009 09:12peter_ir
Так у вас же именно то, о чём предупреждал lkanter.
Надо загрузиться в текстовом режиме и сделать, что он сказал.
Для этого или при загрузке передать ядру параметр "init 3", или загрузитьс с установчного диска в Recovery Console
и в /etc/inittab установить initdefault в 3.
Re: Установка ASPLinux 14 на разделы от 12 27.01.2009 13:14val-888
Здравствуйте!
БОЛЬШОЕ ВАМ СПАСИБО!
Все заработало/
Я очень вам благодарен

RSS-материал