Проблема с inittab...

Автор: judge_aleks Дата: 02.04.2009 08:12 Почему изменение /etc/inittab не приводит с желаемому результату?
вписываю строчку:

S0:345:respawn:/sbin/mgetty -n 2 -D ttyS0 F115200 # Это я пытаюсь поднять Dial-in сервер.

после этого командую

# init q так же пробывал # kill -1 1

ничего не происходит, модем не инициолизируется! mgetty настроен это точно, потому как если его запустить в ручную все работает!!! Начинает принемать звонки. Как сделать чтобы mgetty стартовал вместе ссистемой? Система ASP 14.
Re: Проблема с inittab... 02.04.2009 17:36lkanter Надо бы почитать, чем upstart отличается от sysvinit

judge_aleks Пишет:
-------------------------------------------------------
> Почему изменение /etc/inittab не приводит с
> желаемому результату?
> вписываю строчку:
>
> S0:345:respawn:/sbin/mgetty -n 2 -D ttyS0 F115200
> # Это я пытаюсь поднять Dial-in сервер.
>
> после этого командую
>
> # init q так же пробывал # kill -1 1
>
> ничего не происходит, модем не инициолизируется!
> mgetty настроен это точно, потому как если его
> запустить в ручную все работает!!! Начинает
> принемать звонки. Как сделать чтобы mgetty
> стартовал вместе ссистемой? Система ASP 14.
Re: Проблема с inittab... 03.04.2009 08:48judge_aleks lkanter Пишет:
-------------------------------------------------------
> Надо бы почитать, чем upstart отличается от
> sysvinit

спасибо за подсказку почитал тут [www.ashep.org] про upstart, буду изучать.
lkanter подскажите пожалуйста, чтобы я долго не мучался Улыбка где и каком месте UpStart необходимо сделать изменения, для моего случая.
Спасибо
Re: Проблема с inittab... 03.04.2009 09:02judge_aleks Если я пропишу мою строчку

start on started /sbin/mgetty -n 2 -D ttyS0 F115200 # этого будет достаточно?

И как им управлять?
Re: Проблема с inittab... 03.04.2009 13:36lkanter cd /etc/event.d

cp tty1 ttyS0

vi ttyS0

дальше всё понятно

заменить

exec /sbin/mingetty tty1

на

exec /sbin/mgetty -n 2 -D ttyS0 F115200
Re: Проблема с inittab... 03.04.2009 17:05judge_aleks спасибо большое так и сделаю...
Re: Проблема с inittab... 07.04.2009 07:09judge_aleks сделал, не хочет работать! После добавления поправленного файла ttyS0 в /etc/event.d модем вообще перестал определятся в системе в /dev его тоже нету. Убираю файлик перегружаюсь всё работает... странно всё это. может проблема в строке инициализации или ещё в чём нибуть
Re: Проблема с inittab... 13.04.2009 06:01judge_aleks Народ так кто нить подскажет как в 14 запускать проги вместе с системой?
Re: Проблема с inittab... 13.04.2009 08:30BigAndy Как и везде. rc.local.local.
Re: Проблема с inittab... 13.04.2009 22:16lkanter BigAndy Пишет:
-------------------------------------------------------
> Как и везде. rc.local.local.


Запускать *getty из rc.local.local? Полный бред. Учите матчасть, перед тем как такие советы давать. Это компетенция только процесса init и настраивается в ее конфигурации.
Re: Проблема с inittab... 13.04.2009 22:19BigAndy lkanter Пишет:
-------------------------------------------------------
> BigAndy Пишет:
> --------------------------------------------------
> -----
> > Как и везде. rc.local.local.
>
>
> Запускать *getty из rc.local.local? Полный бред.
> Учите матчасть, перед тем как такие советы давать.
> Это компетенция только процесса init и
> настраивается в ее конфигурации.
Э-эм... Где речь идет о getty????
Вопрос звучит (цитирую)
Цитата:
Народ так кто нить подскажет как в 14 запускать проги вместе с системой?

Имею подозрения, что вопрошащий вообще хочет запускать прогаммы в DE, Но ответил на тот вопрос, который задали....
Re: Проблема с inittab... 14.04.2009 00:21lkanter Может вопрошающий до сих пор не решил ту проблему, с которой тред начинал?
Re: Проблема с inittab... 14.04.2009 08:32judge_aleks Так и не решил.... Грустный вообще какая система инициализации используется в 14? Как я понял init отпадает он уже давно используется только для чтения дефолтного уровня загрузки (run level).
Re: Проблема с inittab... 14.04.2009 09:02peter_ir judge_aleks Пишет:
-------------------------------------------------------
> Народ так кто нить подскажет как в 14 запускать
> проги вместе с системой?
Например, так же, как и раньше, они запускаются при старте системы скриптами в /etc/init.d
при наличии на них ссылок в /etc/rc<n>.d и так же и останавливаются.
Смотрите примеры.
Re: Проблема с inittab... 14.04.2009 13:17judge_aleks peter_ir Пишет:
-------------------------------------------------------

> Смотрите примеры.

где смотреть?
Re: Проблема с inittab... 14.04.2009 13:43peter_ir judge_aleks Пишет:
-------------------------------------------------------
> peter_ir Пишет:
> --------------------------------------------------
> -----
>
> > Смотрите примеры.
>
> где смотреть?

В названных мной каталогах, о чём можно было и догадаться.
RSS-материал