Adobe Flash Player постоянно требует установки

Автор: karymov Дата: 10.04.2009 08:14 Добрый день!
Возникла проблема. Или я такой счастливый, или происки чьи-то.
Несколько дней назад Firefox попросил установить Adobe Flash Player, ранее уже все работало, но попросил и Бог с ним, надо, так надо.
Скачал, установил (flash-plugin-10.0.22.87-release.i386.rpm), баннеры заработали в прежнем режиме.
Через пару дней история повторилась - баннеров нет, требует установить плагины. Пытаюсь скачать и обнаруживаю, что версия плагинов на сайте Адобе не изменилась и ставить снова ту же версию плагина Линукс не дает, разумеется.
Пытаюсь удалить плагин из Линукс, чтобы поставить заново - не удаляется. Точнее пишет, что удален, но остается на месте, как ни в чем ни бывало.
Удалял через yum:
[root@Karymov Документы]# yum remove flash-plugin
Loaded plugins: refresh-packagekit
Setting up Remove Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package flash-plugin.i386 0:10.0.22.87-release set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================
Package Арх. Версия Repository Size
============================================================================================================================================================
Removing:
flash-plugin i386 10.0.22.87-release installed 9.7 M

Transaction Summary
============================================================================================================================================================
Install 0 Package(s)
Update 0 Package(s)
Remove 1 Package(s)

Выполнить [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
/var/tmp/rpm-tmp.14584: line 2: /usr/lib/flash-plugin/setup: Нет такого файла или каталога

Removed:
flash-plugin.i386 0:10.0.22.87-release

Complete!


А в итоге на yum list installed:

flash-plugin.i386 10.0.22.87-release installed

Как это вылечить? Спасибо.
Re: Adobe Flash Player постоянно требует установки 10.04.2009 08:53BigAndy karymov Пишет:
-------------------------------------------------------

>
> Как это вылечить? Спасибо.
rpm -e
Re: Adobe Flash Player постоянно требует установки 10.04.2009 09:00peter_ir Какие-то странные проблемы.
Если я устанавливал flash-plugin от Adobe, то я скачивал его в виде tar.gz, потом ничего не пропадало.
В данном случае надо удалить установленный flash-...rpm командой "rpm -e", м.б, "rpm -e --nodeps"
и потом установить flash-plugin-..rpm из обновлений ASPLinux, yum install flash-...rpm.
Re: Adobe Flash Player постоянно требует установки 10.04.2009 09:44karymov Вот, что вышло:
[root@Karymov Документы]# rpm -e --nodeps flash-plugin
/var/tmp/rpm-tmp.62709: line 2: /usr/lib/flash-plugin/setup: Нет такого файла или каталога
ошибка: %preun(flash-plugin-10.0.22.87-release.i386) scriptlet failed, exit status 127
[root@Karymov Документы]#

А вообще ставил на самом деле первоначально именно с сайта Adobe. После устновки Линукса при первом запуске в Firefox страницы, где требовался флэш, предлагалось установить этот плагин вручную и отсылало меня на сайт Адобе. Ранее таких проблем не было.
Re: Adobe Flash Player постоянно требует установки 10.04.2009 09:59karymov Нашел такую комбинацию в гугле:
rpm -e --nodeps --noscript --noscripts --notriggers
Вроде пакет пропал из списка.
Далее:
[root@Karymov Документы]# yum install flash-plugin
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package flash-plugin.i386 0:10.0.22.87-release set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================
Package Арх. Версия Repository Size
============================================================================================================================================================
Installing:
flash-plugin i386 10.0.22.87-release adobe-linux-i386 3.9 M

Transaction Summary
============================================================================================================================================================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total size: 3.9 M
Выполнить [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : flash-plugin 1/1

NOTICE:
Files belonging to older Flash plugins have been removed from the filesystem. For your safety these files have been saved in /root/oldflashplugins.tar.gz. You may remove this tarball if these files are no longer required.

Installed:
flash-plugin.i386 0:10.0.22.87-release

Complete!


Но баннеры не появились......
Re: Adobe Flash Player постоянно требует установки 10.04.2009 10:02BigAndy karymov Пишет:
-------------------------------------------------------
> Вот, что вышло:
> # rpm -e --nodeps flash-plugin
> /var/tmp/rpm-tmp.62709: line 2:
> /usr/lib/flash-plugin/setup: Нет такого файла или
> каталога
> ошибка:
> %preun(flash-plugin-10.0.22.87-release.i386)
> scriptlet failed, exit status 127
> #
rpm -Va --nofiles
rpm -qa | frep flash
>
> А вообще ставил на самом деле первоначально именно
> с сайта Adobe.
Тогда все вопросы в Эйдобу. Чем вам штатный flash-plugin не подошел?
Re: Adobe Flash Player постоянно требует установки 10.04.2009 10:12karymov Все заработало после перезагрузки.
Т.е. в итоге:
1) rpm -e --nodeps --noscript --noscripts --notriggers flash-plugin
2) yum install flash-plugin
3) перезагрузка
Все пока работает.
Спасибо за советы!
Re: Adobe Flash Player постоянно требует установки 10.04.2009 20:28lkanter Адобовцы вообще не умеют писать скрипты rpm. При каждом обновлении adobe reader слетают привязки типов mime и элементы меню. Приходится не обновлять старый, а удалять и потом ставить новый.
Re: Adobe Flash Player постоянно требует установки 10.04.2009 22:25lg >Адобовцы вообще не умеют писать скрипты rpm.
Ладно бы просто не умели
(проверяем, что мы не сошли с ума, а потом устанавливаем замечательный пакет)
[root@swarm ~]# ls -1 |grep -ve '[a-z]\{1,\}'
Видео
Документы
Загрузки
Картинки
Музыка
Общедоступные
Рабочий стол
Шаблоны
[root@swarm ~]# ls -1 /|grep -ve '[a-z]\{1,\}'
[root@swarm ~]# rpm -ivh /home/storage/repo/linux/rpm/extras/AdbeRdr9.1.0-1_i486linux_enu.rpm 
Подготовка...     ########################################### [100%]
   1:AdobeReader_enu        ########################################### [100%]


А теперь фанфары Улыбка
[root@swarm ~]# ls -1 |grep -ve '[a-z]\{1,\}'
Видео
Документы
Загрузки
Картинки
Музыка
Общедоступные
Рабочий
Рабочий стол
Шаблоны
[root@swarm ~]# ls -1 /|grep -ve '[a-z]\{1,\}'
стол
[root@swarm ~]# ll /стол ~/Рабочий
/root/Рабочий:
итого 4
-rw------- 1 root root 371 Апр 10 22:10 AdobeReader.desktop

/стол:
итого 4
-rw------- 1 root root 371 Апр 10 22:10 AdobeReader.desktop
[root@swarm ~]# 

Ну ведь правда прелесть.....
Re: Adobe Flash Player постоянно требует установки 11.04.2009 08:06tiger А я вот сразу выбирал у ADOBE установку через YUM.
Закачивается пакет. Потом rpm -i <имя пакета>
Кстати пакет очень маленький и содержит всего-то настройку для yum.
После этого можно запустить YUMEX и там в списке репозиториев можно увидеть новый.
В этом случае для установки доступен не только flash-player, но и другие пакеты от adobe, например, adobe reader.
потом все стандартно, выбрали пакеты и установили.
RSS-материал