Ошибка при установке драйвера nvidia

Аватар пользователя sandyb

ошибка при установке драйвера NVIDIA-Linux-x86-1.0-9746-pkg1.run, после сборки нового ядра (2.6.19 , спасибо IsakovAN)

Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most
frequently when this kernel module was built against the wrong or
improperly configured kernel sources, with a version of gcc that differs
from the one used to build the target kernel, or if a driver such as
rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
obtaining ownership of the NVIDIA graphics device(s).

Please see the log entries 'Kernel module load error' and 'Kernel
messages' at the end of the file '/var/log/nvidia-installer.log' for
more information.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
-1 No such device
-> Kernel messages:
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.8
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7 [PCSPP(,...)]
lp0: using parport0 (interrupt-driven).
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
NFSD: unable to find recovery directory /var/lib/nfs/v4recovery
NFSD: starting 90-second grace period
eth0: no IPv6 routers present
nfsd: last server has exited
nfsd: unexporting all filesystems
RPC: failed to contact portmap (errno -5).
nvidia: module license 'NVIDIA' taints kernel.
NVRM: The NVIDIA GeForce4 MX 440 GPU installed in this system is
NVRM: supported through the NVIDIA 1.0-96xx Legacy drivers. Please
NVRM: visit http://www.nvidia.com/object/unix.html for more
NVRM: information. The 1.0-9746 NVIDIA driver will ignore
NVRM: this GPU. Continuing probe...
NVRM: No NVIDIA graphics adapter found!
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

Аватар пользователя wildsin

Re: ошибка при установке драйвера nvidia

sandyb писал(а):
NVRM: The NVIDIA GeForce4 MX 440 GPU installed in this system is
NVRM: supported through the NVIDIA 1.0-96xx Legacy drivers. Please
NVRM: visit http://www.nvidia.com/object/unix.html for more
NVRM: information. The 1.0-9746 NVIDIA driver will ignore
NVRM: this GPU. Continuing probe...

вопроса я, правда, не увидел, но, думаю, что проблема в этом...

Аватар пользователя IsakovAN

Re: ошибка при установке драйвера nvidia

wildsin писал(а):
NVIDIA 1.0-96xx Legacy drivers

wildsin писал(а):
думаю, что проблема в этом...

Вы совершенно правы. Для поддержки "старых" карточек нужны другие дрова(Legacy). Все на сайте у них есть.

Аватар пользователя sandyb

ошибка при установке драйвера nvidia

скачал другой драйвер,
make[4]: *** [/tmp/selfgz4874/NVIDIA-Linux-x86-1.0-7184-pkg1/usr/src/nv/nv.o
] Ошибка 1
make[3]: *** [_module_/tmp/selfgz4874/NVIDIA-Linux-x86-1.0-7184-pkg1/usr/src
/nv] Ошибка 2
make[2]: *** [modules] Ошибка 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Ошибка 1
make: *** [module] Ошибка 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

Аватар пользователя IsakovAN

ошибка при установке драйвера nvidia

Пожалуйста, "прикрепите" к вашему сообщению файл /var/log/nvidia-installer.log. Желательно в зазипованном виде.

Аватар пользователя sandyb

Re: ошибка при установке драйвера nvidia

прикрепил

ВложениеРазмер
nvidia-installer.log.zip 989 байт
Аватар пользователя IsakovAN

Re: ошибка при установке драйвера nvidia

Блин, господа, ну тут же все четко написано:

Цитата:
You appear to be running an X server; please exit X before installing.
For further details, please see the section INSTALLING THE NVIDIA DRIVER
in the README available on the Linux driver download page at

Вырубите иксы перед обновлением драйвера!

Аватар пользователя sandyb

Re: ошибка при установке драйвера nvidia

Извините пожалуйсто. Опять по невнимательности не то сделал, я не тот лог прикрепил.
Иксы я конечно вырубаю перед установкой

ВложениеРазмер
nvidia-installer.log.zip 2.74 КБ
Аватар пользователя IsakovAN

Re: ошибка при установке драйвера nvidia

Покажите пожалуйста вывод команды
ls -l /lib/modules/2.6.19.2Sandy_1/* /usr/src/

Аватар пользователя sandyb

Re: ошибка при установке драйвера nvidia

$ ls -l /lib/modules/2.6.19.2Sandy_1/* /usr/src/
lrwxrwxrwx 1 root root 23 Апр 9 12:33 /lib/modules/2.6.19.2Sandy_1/build -> /usr/src/linux-2.6.19.2
-rw-r--r-- 1 root root 36019 Апр 9 12:33 /lib/modules/2.6.19.2Sandy_1/modules.alias
-rw-r--r-- 1 root root 69 Апр 9 12:33 /lib/modules/2.6.19.2Sandy_1/modules.ccwmap
-rw-r--r-- 1 root root 36209 Апр 9 12:33 /lib/modules/2.6.19.2Sandy_1/modules.dep
-rw-r--r-- 1 root root 73 Апр 9 12:33 /lib/modules/2.6.19.2Sandy_1/modules.ieee1394map
-rw-r--r-- 1 root root 132 Апр 9 12:33 /lib/modules/2.6.19.2Sandy_1/modules.inputmap
-rw-r--r-- 1 root root 697 Апр 9 12:33 /lib/modules/2.6.19.2Sandy_1/modules.isapnpmap
-rw-r--r-- 1 root root 32131 Апр 9 12:33 /lib/modules/2.6.19.2Sandy_1/modules.pcimap
-rw-r--r-- 1 root root 48079 Апр 9 12:33 /lib/modules/2.6.19.2Sandy_1/modules.symbols
-rw-r--r-- 1 root root 38923 Апр 9 12:33 /lib/modules/2.6.19.2Sandy_1/modules.usbmap
lrwxrwxrwx 1 root root 23 Апр 9 12:33 /lib/modules/2.6.19.2Sandy_1/source -> /usr/src/linux-2.6.19.2

/lib/modules/2.6.19.2Sandy_1/kernel:
итого 32
drwxr-xr-x 3 root root 4096 Апр 9 12:33 arch
drwxr-xr-x 2 root root 4096 Апр 9 12:33 crypto
drwxr-xr-x 22 root root 4096 Апр 9 12:49 drivers
drwxr-xr-x 33 root root 4096 Апр 9 12:33 fs
drwxr-xr-x 2 root root 4096 Апр 9 12:33 kernel
drwxr-xr-x 2 root root 4096 Апр 9 12:33 lib
drwxr-xr-x 13 root root 4096 Апр 9 12:33 net
drwxr-xr-x 4 root root 4096 Апр 9 12:33 sound

/usr/src/:
итого 67264
drwxr-xr-x 7 root root 4096 Ноя 30 05:44 asplinux
drwxr-xr-x 3 root root 4096 Апр 3 11:27 kernels
lrwxrwxrwx 1 root root 14 Апр 4 11:49 linux -> linux-2.6.19.2
drwxr-xr-x 20 root root 4096 Апр 9 12:31 linux-2.6.19.2
-r--r--r-- 1 fat fat 42729366 Мар 16 08:25 linux-2.6.19.2.tar.bz2
drwxr-xr-x 3 root root 4096 Апр 6 09:12 NVIDIA-Linux-x86-1.0-7184-pkg1
-rw-r--r-- 1 fat fat 11508286 Апр 5 14:52 NVIDIA-Linux-x86-1.0-7184-pkg1.run
drwxr-xr-x 3 root root 4096 Мар 26 10:13 NVIDIA-Linux-x86-1.0-9746-pkg1
-r--r--r-- 1 fat fat 14521900 Мар 16 07:27 NVIDIA-Linux-x86-1.0-9746-pkg1.run
-rw-rw-rw- 1 root root 52 Янв 10 22:10 pax_global_header

Аватар пользователя IsakovAN

Re: ошибка при установке драйвера nvidia

Ок. Я так понимаю, что /usr/src/linux ядро распаковано и конфиг от текущего ядра в файле .config лежит?
Зайдите в /usr/src/linux и сделайте make prepare после чего запустите установку драйверов по новой.
Похоже проблема возникла из-за того, что после установки ядра вы выполнили make mrpropper или make clean.

Аватар пользователя sandyb

Re: ошибка при установке драйвера nvidia

таже самая ошибка

ВложениеРазмер
nvidia-installer.log.zip 2.74 КБ
Аватар пользователя wildsin

Re: старые Nvidia GF, GF2 (Re: ошибка при установке драйвера

wildsin писал(а):
sandyb,
Цитата:

NVRM: The NVIDIA GeForce4 MX 440 GPU installed in this system is
NVRM: supported through the NVIDIA 1.0-96xx Legacy drivers. Please
NVRM: visit http://www.nvidia.com/object/unix.html for more
NVRM: information. The 1.0-9746 NVIDIA driver will ignore
NVRM: this GPU. Continuing probe...

теста ради поставил на АСП 11.0 ядро 2.6.20 от АСП 11.2 и старенькую Nvidia GeForce2 GTS, которая драйверами версии 9755 от производителя не поддерживается. с www.nvidia.com вытянул драйвер версии 7184...

Цитата:
http://download.nvidia.com/XFree86/Linux-x86/1.0-7184/NVIDIA-Linux-x86-1.0-7184-pkg1.run

исходники (в принципе достаточно девел-пакета текущего ядра) ядра установлены и сконфигурированы правильно... рекомендованный запуск процедуры установки, а именно

Цитата:
# sh NVIDIA-Linux-x86-1.0-8174-pkg1.run

результатов не принес... вылет с ошибкой

Цитата:
/home/wildcat/work/src.../nv/nv-linux.h:17:26:
error: linux/config.h: No such file or directory

разбор полетов привел к следующим выводам:
1. вместо запуска по умолчанию, запустить инсталлер с ключом -х (extract only)

Цитата:
# sh NVIDIA-Linux-x86-1.0-8174-pkg1.run -x

2. перейти в каталог

Цитата:
# cd NVIDIA-Linux-x86-1.0-7184-pkg1/usr/src/nv

3. в файле nv-linux.h в строке №17 изменить config.h на autoconf.h

Цитата:
#include

4. выйти в корень дерева исходников и запустить nvidia-installer

Цитата:
# cd ../../../
# nvidia-installer

5. согласиться с лицензией, отказаться от поиска на сайте nvidia предкомпилированного драйвера, потому как nvidia все равно об ASP Linux не знает и дождаться конца работы установщика...

все... телемаркет... glxgears, запущенный по умолчанию, показывает в среднем 2500 FPS, что само по себе очень неплохо...
hardware: Celeron CPU 1200MHz, 256 Mb RAM, Nvidia GeForce2 GTS (10DE:0150) 32 Mb VideoRAM.
software: ASP Linux 11.0, kernel-2.6.20-1.2312.0.112asp (от ASP 11.2), xorg 6.8.2...

может кому ЭТО поможет насладиться аппаратным ускорением на старых картах и новых дистрибутивах...

PS. только что посмотрел на сайте nvidia... последние Legacy драйверы 7185 уже не поддерживают чипсет 0150, так что желающим использовать более поздние версии драйверов рекомендую смотреть на вывод "lspci -n" и читать "APPENDIX A: SUPPORTED NVIDIA GRAPHICS CHIPS" в README конкретного драйвера на сайте производителя.

to moderators: если (с вашей точки зрения) пост заслуживает внимания, внесите его, пожалуйста, в ЧаВО и/или базу знаний. вопрос с (С) на текст - на ваше усмотрение.

RSS-материал