Нужны библиотеки!!!

Аватар пользователя THE_Beginner

нужны библиотеки для sim подскажите пожалуйста где взять?! SIM качал из инета! Дисков с дистрибутивами linux под рукой нет!

libcrypto.so.0.9.7 is needed by sim-0.9.5-1.i586
libexpat.so.0 is needed by sim-0.9.5-1.i586
libssl.so.0.9.7 is needed by sim-0.9.5-1.i586

Заранее огромное спасибо!

Аватар пользователя Meloman

нужны библиотеки!!!

Возможно, вопрос покажется Вам глупым, но... А чем не угодил sim, который идет в стандартной комплектации? Согласен, собранный, да еще и рпм, это "не для крутых пацанов", но это таки работает Улыбка

Аватар пользователя DRVTiny

Re: нужны библиотеки!!!

2Meloman:
Он же сразу сказал, что нет дистрибутивных дисков. Можно, конечно, скачать simp с ftp.asplinux.ru, но только, как я подозреваю, он именно это и сделал.
2THE_Beginner
На самом деле названные Вами библиотеки в системе с вероятонстью 99,9% есть, просто в Fedor'е и ASP'е вечная проблема с тем, что в /usr/lib для них нужные символьные ссылки отсутствуют.

# file /usr/lib/libcrypto.so.0.9.7
/usr/lib/libcrypto.so.0.9.7: symbolic link to `/usr/lib/libcrypto.so'
# file /usr/lib/libssl.so.0.9.7
/usr/lib/libssl.so.0.9.7: symbolic link to `/usr/lib/libssl.so'
# file /usr/lib/libexpat.so.0
/usr/lib/libexpat.so.0: symbolic link to `libexpat.so.0.5.0'

Для последнего (libexpat) Вам, скорее всего, придётся поставить пакет expat-1.95.8-6 (или что-нибудь поновее), потому что этой библиоткеи у Вас по-видимому действительно нет, а вот с первыми проблема решается на раз:

(под root'ом)
cd /usr/lib
ln -s libssl.so libssl.so.0.9.7
ln -s libcrypto.so libcrypto.so.0.9.7
ldconfig

Аватар пользователя WebCode

Re: нужны библиотеки!!!

Попробуйте поставить openssl. Или настроить yum репозиторий.

Аватар пользователя DRVTiny

нужны библиотеки!!!


rpm -ql openssl | grep lib
/lib/libcrypto.so.0.9.7f
/lib/libcrypto.so.5
/lib/libssl.so.0.9.7f
/lib/libssl.so.5

OpenSSL у него с вероятностью 99,9% есть (от этого пакета зависит чуть не половина дистрибутива), только вот ссылки при установке создаются не там и неправильные.

Аватар пользователя 5am3_

Re: нужны библиотеки!!!

спасибо огромное, совет с линковкой выручил...

Аватар пользователя Vlad5503

Re: нужны библиотеки!!!

DRVTiny писал(а):
2Meloman:
Он же сразу сказал, что нет дистрибутивных дисков. Можно, конечно, скачать simp с ftp.asplinux.ru, но только, как я подозреваю, он именно это и сделал.
2THE_Beginner
На самом деле названные Вами библиотеки в системе с вероятонстью 99,9% есть, просто в Fedor'е и ASP'е вечная проблема с тем, что в /usr/lib для них нужные символьные ссылки отсутствуют.

# file /usr/lib/libcrypto.so.0.9.7
/usr/lib/libcrypto.so.0.9.7: symbolic link to `/usr/lib/libcrypto.so'
# file /usr/lib/libssl.so.0.9.7
/usr/lib/libssl.so.0.9.7: symbolic link to `/usr/lib/libssl.so'
# file /usr/lib/libexpat.so.0
/usr/lib/libexpat.so.0: symbolic link to `libexpat.so.0.5.0'

Для последнего (libexpat) Вам, скорее всего, придётся поставить пакет expat-1.95.8-6 (или что-нибудь поновее), потому что этой библиоткеи у Вас по-видимому действительно нет, а вот с первыми проблема решается на раз:

(под root'ом)
cd /usr/lib
ln -s libssl.so libssl.so.0.9.7
ln -s libcrypto.so libcrypto.so.0.9.7
ldconfig

Вот что-то с линковыми у меня не заработало.
пытаюсь поднять спутниковый инет на карточке SS2+спринт. Может кто знает как "извернуться" ?

RSS-материал