Ati драйвера??

Аватар пользователя aliens

Здравствуйте!

Стоит asp11, не могу поставить open GL для видеокарты ATI X600... когда была установка я поставил mesa драйвера.а как теперь поставить fglrx я незнаю! при установке из .run пакета скаченого с оф сайта пишет такое
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Error] Kernel Module : No kernel module build environment - please consult readme.

а при установки с дистрибутива пакета ati-fglrx-8.21.7.1-0.1.110asp.i386.rpm если ключ -i только ставить то находит кучу конфликтных модулей (которые я потом удалил и тож самое)
если принудительно -i --force то показывает что ставится,но опен гл не пашет, если -ivh то
Подготовка... ########################################### [100%]
1:ati-fglrx ########################################### [100%]

и тож не пашет Грустный с включеными и выклчюеными иксами одинаково все Грустный
помогите плиз

еще забыл добавить,что првоеряю все glxgears, и там появляется ошибка
Xlib: extension "GLX" missing on display ":0.0".
glxgears: Error: couldn't get an RGB, Double-buffered visual.

Аватар пользователя alex_root

Re: ati драйвера??

kernel-source стоит?

Аватар пользователя Cherepulya

Re: ati драйвера??

yum install kernel-module-fglrx

Аватар пользователя aliens

Re: ati драйвера??

Цитата:
alex_root пишет:
kernel-source стоит?

откуда его брать ? и куда ставить.

а вот yum попробую! спасибо!

а после этого ставить из .run ?

Аватар пользователя woodoo

Re: ati драйвера??

aliens писал(а):
откуда его брать ? и куда ставить.

kernel-devel, точнее.

Аватар пользователя Cherepulya

Re: ati драйвера??

aliens писал(а):
а вот yum попробую! спасибо!

а после этого ставить из .run ?

ничего больше не ставить. Просто набрать в консоди из под рута yum install kernel-module-fglrx
Драйвера поставятся сами. Потянув в том числе ati-fglrx

После этого в конфиге иксов сменить используемый драйвер с radeon на fglrx

Аватар пользователя aliens

Re: ati драйвера??

хм... пробую yum пишет такое
[root@MARS bin]# yum install kernel-module-fglrx
Setting up Install Process
Setting up repositories
base 100% |=========================| 951 B 00:00
updates-released 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 5.1 MB 00:01
http://download.asplinux.ru/i386/RPMS.11/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from base: [Errno 256] No more mirrors to try.

Грустный

Аватар пользователя Cherepulya

Re: ati драйвера??

yum clean all
yum install kernel-module-fglrx

Просто что-то скачалось битым и не соответсвует контрольной сумме. Нужно почистить кеши и повторить заново.

Аватар пользователя woodoo

Re: ati драйвера??

Cherepulya писал(а):
yum install kernel-module-fglrx

Не, нет такого пакета. В имя именно этого пакета входит версия ядра.

# yum list kernel-module-fglrx\*
Setting up repositories
...
Available Packages
kernel-module-fglrx-2.6.14-1.1653.1asp.i 8.21.7.1-0.1.110asp    local.base
kernel-module-fglrx-2.6.14-1.1653.1aspsm 8.21.7.1-0.1.110asp    local.base
kernel-module-fglrx-2.6.16-1.2096asp.i68 8.24.8.1-0.1.110asp    updates-released
kernel-module-fglrx-2.6.16-1.2096aspsmp. 8.24.8.1-0.1.110asp    updates-released
kernel-module-fglrx-2.6.16-1.2108asp.i68 8.24.8.1-0.1.110asp    updates-released
kernel-module-fglrx-2.6.16-1.2108aspsmp. 8.24.8.1-0.1.110asp    updates-released
kernel-module-fglrx-2.6.16-1.2111asp.i68 8.24.8.1-0.1.110asp    updates-released
kernel-module-fglrx-2.6.16-1.2111aspsmp. 8.24.8.1-0.1.110asp    updates-released
kernel-module-fglrx-2.6.16-1.2115asp.i68 8.24.8.1-0.1.110asp    updates-released
kernel-module-fglrx-2.6.16-1.2115aspsmp. 8.24.8.1-0.1.110asp    updates-released

Главное: все-таки определиться, что в итоге хочет автор вопроса:
- поставить оригинальные драйверы
- поставить сборку для ASPLinux 11.

Аватар пользователя Cherepulya

Re: ati драйвера??

woodoo писал(а):
Не, нет такого пакета. В имя именно этого пакета входит версия ядра.

У меня - есть Улыбка

[root@localhost 1]# yum install kernel-module-fglrx
Setting up Install Process
Setting up repositories
base                      100% |=========================|  951 B    00:00
updates-released          100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kernel-module-fglrx-2.6.16-1.2111asp to pack into transaction set.
kernel-module-fglrx-2.6.1 100% |=========================|  11 kB    00:00
---> Package kernel-module-fglrx-2.6.16-1.2111asp.i686 0:8.24.8.1-0.1.110asp set to be updated
--> Running transaction check
--> Processing Dependency: /boot/vmlinuz-2.6.16-1.2111asp for package: kernel-module-fglrx-2.6.16-1.2111asp
Importing Additional filelist information for dependency resolution
filelists.xml.gz          100% |=========================| 1.8 MB    00:00
updates-re: ################################################## 802/802
Added 85 new packages, deleted 80 old in 9.98 seconds
--> Processing Dependency: ati-fglrx >= 8.24.8.1-0.lvn.1 for package: kernel-module-fglrx-2.6.16-1.2111asp
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kernel to pack into transaction set.
kernel-2.6.16-1.2111asp.i 100% |=========================| 228 kB    00:00
---> Package kernel.i686 0:2.6.16-1.2111asp set to be installed
---> Downloading header for ati-fglrx to pack into transaction set.
ati-fglrx-8.24.8.1-0.1.11 100% |=========================|  24 kB    00:00
---> Package ati-fglrx.i386 0:8.24.8.1-0.1.110asp set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kernel-module-fglrx-2.6.16-1.2111asp  i686       8.24.8.1-0.1.110asp  updates-released  446 k
Installing for dependencies:
 ati-fglrx               i386       8.24.8.1-0.1.110asp  updates-released  7.1 M
 kernel                  i686       2.6.16-1.2111asp  updates-released   16 M

Transaction Summary
=============================================================================
Install      3 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 23 M

[root@localhost 1]# uname -a
Linux localhost 2.6.16-prep #5 PREEMPT Sat Jun 17 14:20:23 MSD 2006 i686 athlon i386 GNU/Linux

у меня просто 2.6.16-1.2111asp из src-rpm перебранное

Аватар пользователя aliens

Re: ati драйвера??

woodoo писал(а):
Главное: все-таки определиться, что в итоге хочет автор вопроса:
- поставить оригинальные драйверы
- поставить сборку для ASPLinux 11.

Я хочу драйвера,которые держат OpenGL Улыбка а откуда и чьи мне пофиг впринципе,ну а вообще которые постабильнее хотелось бы...

Аватар пользователя aliens

Re: ati драйвера??

Цитата:
Cherepulya пишет:
yum clean all
yum install kernel-module-fglrx

Просто что-то скачалось битым и не соответсвует контрольной сумме. Нужно почистить кеши и повторить заново.

все сделал,он убрал 5 metadata files а потом такая же проблема:( похоже он не может скачать этот файл primary.xml.gz

что еще можно сделать??

P.S. вопрос такой, а по какому порту он качает? а то у меня у провайдера открыты только порты с 1024 и 80

kernel-devel стоит

Аватар пользователя woodoo

Re: ati драйвера??

Цитата:
aliens пишет:
P.S. вопрос такой, а по какому порту он качает?

Если в конфиге baseurl репозитория прописан http:// - то по 80. Если ftp:// - то "нет".
Видимо, второе.

Аватар пользователя aliens

Re: ati драйвера??

Здравствуйте опять!

В общем у меня полетел винчестер и я заново ставил линукс. Поставил,все зхаработало, решил с сайта АТи скачать и обновить драйвера... (черт меня дернул) и поставил из из пакета ati-driver-installer-8.26.18-x86.run ...поставил, open GL исчез....и в асти контрол написано mesa driver Грустный ну решил поставлю еще изи пакет .rpm ...пробовал с флагами -i ; -U и -i --force...не ставится пишет вот такую фигню:
libexpat.so.1 нужен для fglrx_6_8_0-8.26.18-1.i386
Хотя этот файл лежит в /usr/lib/

Подскажите что делать! переставлять линукс не хочу )) настроил уже немного....

P.S. YUM Extender почему то не может скачать primary.xml (( я настройки его не трогал.

Аватар пользователя woodoo

Re: ati драйвера??

woodoo писал(а):
Главное: все-таки определиться, что в итоге хочет автор вопроса:
- поставить оригинальные драйверы
- поставить сборку для ASPLinux 11.

Ы? ;-)

Аватар пользователя aliens

Re: ati драйвера??

Цитата:
woodoo пишет:

woodoo писал(а):
Главное: все-таки определиться, что в итоге хочет автор вопроса:
- поставить оригинальные драйверы
- поставить сборку для ASPLinux 11.

Ы? ;-)

хочется драйвера которые нормально понимают OpenGL. В данный момент наверно я хочу вернуться к сборке для ASP... помогите плиз

RSS-материал