При включении ПК ошибка запуска HAL

Аватар пользователя dacha

Здравствуйте!

Такая проблема. При включении ПК (ASPLinux 11) уже второй день наблюдаю ошибку запуска HAL, сопровождающуюся обращением к FDD. То есть haldaemon не запускается.

После загрузки пытаюсь сделать вручную его запуск, в результате возникает три окна:
одно об ошибке "haldaemon failed. The error was: Запускається служба HAL: [НЕВДАЧА]"
и два похожи на виндовые, когда windows обнаруживает новый носитель и спрашивает, что с ним делать, - касательно hdc и fd0.

Понимаю, что информация о проблеме неполная, подскажите, какие логи привести.

С уважением,
dacha.

Аватар пользователя lystor

Re: При включении ПК ошибка запуска HAL

Какая версия hal, dbus?
rpm -q hal
rpm -q dbus

Покажите ввывод:
/usr/sbin/hald --daemon=no --verbose=yes

Аватар пользователя dacha

Re: При включении ПК ошибка запуска HAL

Вот, наконец, появилась возможность ответить Улыбка
То работа, то переезд <КЛASP'a?>

Нашлись грабли Улыбка

И делов-то, всего лишь прокладку надо было поменять.
Ту, которая между стулом и монитором. А шуму, а пыли сколько навел Улыбка

За неимением поддержки добрым и мудрым словом членов Клуба (по известным техническим причинам), начал вспоминать, что делал последнее время.
И что же Вы думаете? Была отключена служба messagebus!
После ее включения и перезагрузки все пошло, как надо.
А я уж было распереживался, думал, что-то сломалось у меня в компьютере.
Как говорят в среде win32, все решилось путем обновления библиотеки hands.dll.

Спасибо lystorу за помощь.
Без этого вопроса, я бы, наверное, не догадался, что дело в messagebus.

Цитата:
lystor пишет:
Какая версия hal, dbus?
rpm -q hal
rpm -q dbus

Покажите ввывод:
/usr/sbin/hald --daemon=no --verbose=yes

Я все же отвечу.

Версии пакетов -
hal-0.5.5.1-1.1asp
dbus-0.50-1

Вывод /usr/sbin/hald --daemon=no --verbose=yes (при включенном messagebus)
10:10:45.127 [I] hald.c:511: hal 0.5.5.1
10:10:45.127 [I] hald.c:575: Will not daemonize
10:10:45.128 [I] hald_dbus.c:3048: local server is listening at unix:abstract=/tmp/hald-local/dbus-VYZmWZ9V00,guid=759e7a44f241df2a7890667baa34cd00
Error binding to /var/run/hal/hotplug_socket2: Address already in use

Вывод /usr/sbin/hald --daemon=no --verbose=yes (при отключенном messagebus)
10:15:47.099 [I] hald.c:511: hal 0.5.5.1
10:15:47.100 [I] hald.c:575: Will not daemonize
10:15:47.100 [I] hald_dbus.c:3048: local server is listening at unix:abstract=/tmp/hald-local/dbus-rJURbO9zc0,guid=a39f7a446175e2d1872d4f79b0491500
10:15:47.100 [I] osspec.c:347: sysfs mount point is '/sys'
10:15:47.100 [I] osspec.c:352: proc mount point is '/proc'
*** [DIE] osspec.c:osspec_init():370 : Unable to bind to netlink socket

Извините за беспокойство...

С уважением,
dacha.

RSS-материал