ASP11 & nForce2

Аватар пользователя ddmitry

Столкнулся с проблемой установки АСП11 на компьютер с материнкой ASUS A7N8X-Deluxe (nForce2 400 Ultra). В системе есть 3 винчестера: 2 SATA (на интегрированном SATA RAID Silicon Imgae 3112A) и 1 IDE. Причём устновить систему хочу на IDE-диск.

В инструкции по установке на SATA описана процедура, которая у меня не выполнима, т.к. до выбора языка дело просто не доходит - система застопоривается. Да и не нужно это, т.к. в выводе проскакивает сообщение об успешной загрузке необходимого модуля для SATA RAID, контроллер и диски система видит.

По ходу загрузки видно много ругани на IRQ, последний экран перед стопором выглядит так:
информация о двух SATA-дисках
sata link up at 1,5Gb/s
IRQ11: nobody cared (попробуйте загрузится в режиме irq poll)
---
много ругани про IRQ
---
IRQ11 disabled
информация о первом SATA-диске

Дальше ничего. Можно войти в busybox, но что там можно сделать, непонятно
На 11-м прерывании висит SATA-RAID контроллер и ещё одно устройство. Манипуляциями в BIOS удаётся оставить это прерывание только контроллеру или сместить его на другое прерывание, но это не помогает. Единственная настройка ACPI - выключение APIC - тоже не помогает.

Из поиска по интернету я понял, что это проблема давно известна и вроде должна была быть решена ещё в ядрах 2.4.хх

Если отключить SATA-диски (не отключая SATA-контроллер) и оставить один IDE, то загрузка доходит до графики. Но каков будет результат, если подключить их после установки? Будут ли они работать?

В общем, видится два варианта: загрузить в указанном режиме irq poll (но как?) и отключить SATA-диск на время установки. Как быть?

Аватар пользователя sergeil

Re: ASP11 & nForce2

Цитата:
ddmitry пишет:
Столкнулся с проблемой установки АСП11 на компьютер с материнкой ASUS A7N8X-Deluxe (nForce2 400 Ultra). В системе есть 3 винчестера: 2 SATA (на интегрированном SATA RAID Silicon Imgae 3112A) и 1 IDE. Причём устновить систему хочу на IDE-диск.

Если IDE предполагается использовать как загрузочный, то нет проблем...
Отключаем контроллеры SATA и ставим... После успешной установки и, желательно, обновления, включаем SATA и смотрим как они поладят... Если плохо, то нужно разрешать аппаратные конфликты...

Поставьте в BIOS, что OS: NO_PnP
Пусть BIOS проинициализирует все оборудование...

Аватар пользователя ddmitry

Re: ASP11 & nForce2

Цитата:
sergeil пишет:

Цитата:
ddmitry пишет:
Столкнулся с проблемой установки АСП11 на компьютер с материнкой ASUS A7N8X-Deluxe (nForce2 400 Ultra). В системе есть 3 винчестера: 2 SATA (на интегрированном SATA RAID Silicon Imgae 3112A) и 1 IDE. Причём устновить систему хочу на IDE-диск.

Если IDE предполагается использовать как загрузочный, то нет проблем...
Отключаем контроллеры SATA и ставим... После успешной установки и, желательно, обновления, включаем SATA и смотрим как они поладят... Если плохо, то нужно разрешать аппаратные конфликты...

Поставьте в BIOS, что OS: NO_PnP
Пусть BIOS проинициализирует все оборудование...

Систему поставил с одним IDE. Контроллер при установке не отключал. После установки подключил SATA-диски, систему стало клинить при загрузке на том же этапе. Текстовый вывод точно такой же. Что удивительно, так это то что клинит не из-за контроллера, а из-за дисков.

Кстати, что скажете по поводу вот этой статьи?
http://www.citforum.ru/open_source/hard_irq/

На сайтах производителей контроллера и материнке статей не нашёл. Наверное, это действительно проблема Linux?..

Аватар пользователя keng00ru

Re: ASP11 & nForce2

Попробуй ACPI отключить. Он иногда считает себя крутым мнеджером прерываний и мешает жить.

Аватар пользователя ddmitry

Re: ASP11 & nForce2

Цитата:
keng00ru пишет:
Попробуй ACPI отключить. Он иногда считает себя крутым мнеджером прерываний и мешает жить.

Увы, нет такой настройки в BIOS (версия последняя на данный момент). Можно отключить только APIC, но это не помогает.

RSS-материал