Yum && rpmbuild --target=pentium4

Аватар пользователя sergeil

FYI

rpmbuild принимает и корректо обрабатывает --target=pentuim4, создавая пакеты, оптимизированные под pentium4, а rpm корректно с ними работает. Но, если вы попытаетесь создать репозитарий YUM на базе этих пакетов, то вас ждет большое разочарование. YUM игнорирует эти пакеты, считая чужеродными. При этом он умеет их удалять, если уже установлены. Обновление YUM до версии 2.5.1 не дало желаемого результата.
Грустный

Аватар пользователя rjaan

Re: yum && rpmbuild --target=pentium4

sergeil

Цитата:
--target=pentuim4

Мне кажется это не общая проблема yum'а - надо смотреть сам скрипт, где эти пакеты игнорируются.

Аватар пользователя sergeil

Re: yum && rpmbuild --target=pentium4

rjaan

Цитата:
Мне кажется это не общая проблема yum'а - надо смотреть сам скрипт, где эти пакеты игнорируются.

Проблема не в том, что-бы найти эти строчки и подправить, а что-бы это было исправлено в основной ветке продукта. Вы можете исправить у себя и все будет нормально, но созданные Вами пакеты сможете использовать только Вы и больше никто. Не каждому под силу править скрипты. Тем более, что первое-же обновление yum сведет на нет все Ваши усилия. Yum будет стабилизироваться и обновлятся. И Вы будете вынуждены его постоянно править. Насколько я знаю, даже версия yum-2.5.1, которая еще не поддерживает 'pentium4', не предполагается в asplinux-11. То есть, в yum-2.4.x она уже точно поддерживаться не будет. Какая у нас есть штатная альтернатива yum в asplinux? Наверное, никакой...

Аватар пользователя slavaz

Re: yum && rpmbuild --target=pentium4

Вывод: слать патчи разработчикам и теребить их до наблюдения своего патча в следующей версии приложения... Улыбка

RSS-материал